UI slowness and ingestion delays in US

Incident Report for DataSet

Resolved

This incident has been resolved.
Posted Apr 29, 2022 - 19:07 UTC

Monitoring

Performance has been restored and we are continuing to monitor
Posted Apr 29, 2022 - 18:29 UTC

Investigating

We are currently investigating reports of UI slowness and ingestion delays in US
Posted Apr 29, 2022 - 18:19 UTC