Maintenance window for EU Cluster
Incident Report for DataSet
Resolved
Maintenance has been completed
Posted Mar 04, 2022 - 00:28 UTC
Investigating
We are currently conducting scheduled maintenance which may impact UI and ingestion for EU accounts
Posted Mar 04, 2022 - 00:07 UTC