Query delays in US region
Incident Report for DataSet
Resolved
Remedial action has been taken and the issue is resolved.
Posted Feb 17, 2021 - 19:53 UTC
Investigating
We are currently investigating an issue which is causing slow query times for some customers.
Posted Feb 17, 2021 - 19:41 UTC