Increase in email delivery failures
Incident Report for Scalyr
Resolved
This incident has been resolved.
Posted May 17, 2021 - 22:43 UTC
Identified
We are currently experiencing an increase in email delivery failures which began at approximately 18:00 GMT Saturday May 15. The issue has been identified and a fix is being implemented.
Posted May 17, 2021 - 21:22 UTC