eu.scalyr.com missing logs from some older agents
Incident Report for DataSet
Resolved
As a result of the deployment of a new certificate on eu.scalyr.com, ingestion was interrupted for certain older Scalyr Agents sending data to this cluster as of approximately 15:00 GMT. We have now reverted this change.

This issue impacts those environments using a Scalyr Agent prior to 2.1.33 (August 17, 2022) and Python prior to 2.7.9 (December 14, 2014).

Affected customers are advised to update their Scalyr Agents to the latest version (or at least version 2.1.33) by Wednesday, October 11. We plan to deploy this change again on Thursday, October 12, 2023.

UPDATE 6 Oct 17:00 UDT: Based on customer requests for more time for agent updates, we have canceled plans to deploy this change on Thursday October 12 and will post another update here by end of day, Tuesday October 10.

UPDATE 10 Oct 17:30 UDT: We have identified a path forward which will continue to support these older environments (Scalyr Agent prior to 2.1.33 and Python prior to 2.7.9), so we have eliminated the need to update for the time being. We will be sunsetting support for these environments within the next year but will provide advance notice.
Posted Oct 05, 2023 - 22:00 UTC